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Introduction
This exercise will introduce you to the  Benthic Terrain Modeler, a
collection of ESRI® ArcGIS®-based tools that coastal and marine
resource managers can use in concert with bathymetric data sets, in
order to examine and classify the benthic environment.

The BTM toolbar contains a set of tools that allow users to create
grids of slope, bathymetric position index and rugosity from an input
data set. An integrated XML-based terrain classification dictionary
gives users the freedom to create their own classifications and
define the relationships that characterize them. A unique feature of
the tool is its wizard-like functionality that steps users through the
processes involved in benthic terrain characterization, and provides
access to information on key concepts along the way.

Benthic Terrain Modeler

Skills Learned Tools and Technology
ArcGIS Components

• ArcMap

ArcGIS Extension
• Spatial Analyst
• Benthic Terrain Modeler

•Creating a Bathymetric Position Index (BPI) Grid
•Loading a Classification Dictionary
•Creating a Rugosity Grid
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Create a Broad Scale BPIBathymetric Position Index (BPI)

The concept of bathymetric position is central to the benthic
terrain classification process that is utilized by the BTM.
Bathymetric Position Index (BPI) is a measure of where a
referenced location is relative to the locations surrounding it.
BPI is derived from an input bathymetric data set and itself is a
modification of the topographic position index (TPI) algorithm
that is used in the terrestrial environment. The application of
TPI to develop terrain classifications was explored and
developed by Andrew Weiss during his study of terrestrial
watersheds in Central Oregon (Weiss 2001). These
applications can be carried into the benthic environment
through BPI.

Bathymetric Position Index (BPI) data sets are created through
a neighborhood analysis function. Positive cell values within a
BPI data set denote features and regions that are higher than
the surrounding area. Therefore, areas of positive values
generally characterize ridges and other associated features
within the benthic terrain. Likewise, negative cell values within
a BPI data set denote features and regions that are lower than
the surrounding area. Areas of negative cell values generally
characterize valleys and other associated features within a
bathymetric data set (Figure 1). BPI values near zero are either
flat areas (where the slope is near zero) or areas of constant
slope (where the slope of the point is significantly greater than
zero) (Figure 2) (Weiss 2001).
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Bathymetric position is an inherently scale-dependent phenomenon (Weiss 2001). Two different BPI datasets, with
different scale factors, are created during the benthic terrain classification process. Fine scale BPI data sets have
smaller analysis neighborhoods, and thus a smaller scale factor. Fine scale BPI data sets are useful for identifying
smaller benthic terrain features. Broad scale BPI data sets have larger analysis neighborhoods, and thus a larger scale
factor. These data sets are useful in identifying larger benthic terrain regions or areas.

The BTM Tool utiziles the Raster Map Algebra Operation
object, available through the ArcGIS Spatial Analyst extension,
to apply the following algorithm and create an output BPI data
set:
BPI<scalefactor> = int((bathy -
focalmean(bathy,annulus,irad,orad)) + .5)

scalefactor = outer radius in map units * input bathymetric
data set resolution(cell size)
bathy = input bathymetric data set
irad = inner radius of annulus-shaped analysis neighborhood in
cells
orad = outer radius of annulus-shaped analysis neighborhood
in cells

Bathymetric Position Index (BPI)

BPI data sets are created from an input bathymetrc data set by
applying an algorithm that utilizes a focal or neighborhood
function. Neighborhood functions produce an output raster in
which the output cell value at each location is a function of the
input cell value and the values of the cells in a specified
"neighborhood" surrounding that location (Figure 3).
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Standardizing  BPI Grids

Once BPI data sets have been created at both fine and broad scales, the next step in the benthic terrain classification
process is to standardize the values of these raster data sets.

Bathymetric data tends to be spatially autocorrelated (i.e. locations that are closer together are more related than
locations that are farther apart) (Weiss 2001). Therefore, the range of BPI values increases with scale. For example,
broad (small) scale BPI data sets would have smaller BPI values because a larger analysis neighborhood is used. This
would have the effect of averaging out small variations in the terrain. Fine (large) scale BPI data sets would have larger
BPI values because of the smaller neighborhood that is used. This smaller analysis neighborhood would result in the
detection of smaller, localized variations in the terrain.

Standardization of the raw BPI values allows for the classification of BPI data sets at almost any scale (Weiss 2001).
This step also allows easier parameter entry during the classification dictionary editor creation process. Once again, the
BTM utilizes the Raster Map Algebra Operation object available through the ArcGIS Spatial Analyst extension to create
the standardized output data set. The following algorithm is used:

BPI<scalefactor>_std = int((((BPI<scalefactor> - mean) / std dev) * 100) + 0.05)

scalefactor = outer radius in map units * input bathymetric data set resolution(cell size)
mean = mean cell value across BPI data set
std dev= standard deviation of cell values across BPI data set
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Examples of benthic terrain modeling

The BTM tools was used to
produce the first benthic habitat
maps for Fagetele Bay National
Marine Sanctuaries in the
American Samoa.

Various marine structures were
derived using the classification
dictionary.
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Examples of benthic terrain modeling

Methods employed using the BTM
can also be manually created
exclusively using ArcGIS Spatial
Analyst extension.

This example illustrates the
application of bathymetric position
to examine adult rockfish
distribution in Monterey, CA.

Analysis was performed by Pat
Iampietro at the Seafloor Mapping
Lab, California State University,
Monterey Bay.

Courtesy of  Pat Iampietro, CSU-MB, ESRI UC 2003
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Exercise A – The Set-Up

This exercise you will install the Benthic Terrain Modeler, Launch
ArcMap, activate the Spatial Analyst extension and set up your
ArcMap Project.

A. Install the Benthic Terrain Modeler
 Navigate to the Mod1_BTM folder.
 Double-click on the BTMSetup.exe file to launch the BTM

installer.
 Accept the default settings for the installation, complete

the installation as prompted.

Launch ArcMap

C. Load the BTM tool
 Click on View > Toolbars > Benthic Terrain Modeler

Toolbar.

Benthic Terrain Modeler

Screen Grab of ExplorerA

A

C

C
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Exercise A –   The Set-Up Continued

D. Load and activate the Spatial Analyst Extension
 Click on View > Toolbars > Spatial Analyst
 Click on Tools > Extensions. Make sure there is a check

next to the Spatial Analyst box

E. Add the bathymetric and hillshade data for our study area
1. Navigate to the MRM_GIS > Data > Grids folder
2. Add the crml_hs and crml_bth data your ArcMap Project

F. Save your project in the BTM_Mod1 folder
 File > Save > BTM.mxd

Benthic Terrain Modeler

E.1

E.2

F
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Exercise B –   Calculating Bathymetric Position Index (BPI)
In this exercise you will use the Benthic Terrain

Classification Wizard to calculate a benthic position
index grid

Summary of Process Steps
1. Launch the BTM.mxd project that you set up in

Exercise A
2. Launch the Benthic Classification Wizard
3. Create Broad and Fine Scale BPI grids
4. Standardized the BPI grids
5. Use an existing classification dictionary to classify

the BPI grids into terrain zones.

Benthic Terrain Modeler

Final Classified BPI Grid
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Start the process by using the Benthic Terrain
Classification Wizard menu. The Wizard will
guide you through all of the major steps of the
analysis.  The remaining menu choices allow
you to perform any of the steps individually.

Benthic Terrain Modeler

1

1

2

Click on the Benthic Terrain 
Classification Wizard

Click the Next button to launch the Wizard

2
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Set your working directory to
\Mod1_BTM\BTM_Working. All
data from the analysis will be
created in this directory.

Select the bathymetric grid you will
be using as the input data. Navigate
to the Mod1_BTM\Data folder and
select crml_bth grid

(Optional)
If you have previously created BPI
GRIDS, you can specify these
GRIDS in this area.

Click on the Next button.

Benthic Terrain Modeler

2

1

3

1

2
3

4

4
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This step is optional. You can
resample your bathymetric GRIDs to
increase the cell size. We will not
resample our GRID for this exercise.

Make sure the radio dial for No is
selected.

Click on the Next button.

Benthic Terrain Modeler

1

1

12
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5

4

3

Create a Broad Scale BPI

1

2

Type in 1 for the Inner radius

Type in 5 for the Outer radius

Name the output data set
crml_bth_10

Click on Generate GRID

Click on Next

Once the calculation is completed,
add data to your map.

1

2

4

5

3

The creation of Bathymetric Position Index (BPI) data sets at two different scales is central to the methods behind the
benthic terrain classification process. BPI is a derivative of the input bathymetric data set, and is used to define the
location of specific features and regions relative to other features and regions within the same data set.

A broad scale BPI data set allows you to identify smaller features within the benthic landscape.

6

6
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Create a Fine Scale BPI

5

4

3

1

2

Type in 1 for the Inner radius

Type in 3 for the Outer radius

Name the output data set
crml_bth_6

Click on Generate GRID

Click on Next

Once the calculation is completed,
add data to your map.

1

2

4

5

3

The creation of Bathymetric Position Index (BPI) data sets at two different scales is central to the methods behind the
benthic terrain classification process. BPI is a derivative of the input bathymetric data set, and is used to define the
location of specific features and regions relative to other features and regions within the same data set.

A fine scale BPI data set allows you to identify larger regions within the benthic landscape.

6

6
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Create standardized grids for both the fine
and broad scale grids.

Review the statistics for the fine scale BPI
grid

Specify output data set

Specify the name of the output grid as
crml_bth_6st

Click Next -> to activate the Broad Scale
BTP Tab

Repeat the three steps above to set the
parameter for broad scale BPI grid
standardization. Name the output grid
crml_bth_10s

Click Submit to start the standardization
process

Click Next -> to move on the to the next
window

Benthic Terrain Modeler

1

2

3

4

5

6

1

2

5

4

3

Standardizing  BPI Grids

7
5

7
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Upon initialization, the Data Dictionary Editor Tool
will load an empty, default classification dictionary
(defdict.xml) that the user can expand and modify.

We will use a previously created classification
dictionary, click on the Open File button and
navigate to the Module1_BTM directory and select
the basic_zones.xml file.

Click the Next -> button

Specify the name of the new grid

Click Finish

Add the data to your map

Benthic Terrain Modeler

Once BPI data sets been standardized, the next step is to classify the standardized BPI to various benthic zones
and/or structures. Classification is based on BPI parameters, slope and depth. You can specify an existing
Classification dictionary, or you can create a new dictionary. We will use an existing dictionary

1

2

3

4

Classification Dictionary

1

3

2

4

5

5
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Examine the output data and review questions

Benthic Terrain Modeler

Examine the ZONES layer in the
Table of Contents section of the
application window. The ZONES
grid has been classified and
symbolized to depict areas that are
crests, depressions, flats and
slopes.

Examine the intermediate data
layers created to produce the final
ZONES layers.

Which grid layer represents
seafloor depth?
____________________________

What is the difference between
crml_bth_10 and crml_bth_6?
____________________________
____________________________
____________________________
____________________________
What is the difference between
crml_bth6 and crml_bth6st?
____________________________
____________________________
____________________________
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The last step will be to create a rugosity grid.
Rugosity can be best defined as the ratio of surface area to planar area. Basically, rugosity is a measure of terrain complexity or the
"bumpiness" of the terrain. In the benthic environment, rugosity can be used to aid in the identification of areas with high
biodiversity, depending on the scale of the input bathymetry.

The BTM uses a process developed by Jeff Jenness to derive rugosity from an input bathymetric data set. This novel methodology
creates an output that is similar to a Triangulated Irregular Network (TIN), but does not require the ArcGIS 3D Analyst extension for
its creation (figure 1). Similar to BPI data set creation, rugosity derivation relies, in part, on a neighborhood analysis using a 3 grid
cell by 3 grid cell neighborhood. An algorithm is passed through the Raster Map Algebra Operation object within Spatial Analyst that
calculates the planar distance between the center point of the center cell and of each of the eight surrounding cells in the
neighborhood.

Next, using the Pythagorean Theorem, the surface distance is calculated for each planar distance using the difference in elevation
between the cells. The result of this function is sixteen separate grid data sets with each cell value equal to this surface distance.
The next step in the process is to calculate the area formed by three adjacent sides. The result is eight triangular surface area grids.
These grid datasets are combined to obtain a surface area data set for the input bathymetric data set. The final step in the process
is to create a data set that represents the ratio of surface area to planar area. This final data set represents rugosity for the study
area.

Rugosity

Graphics courtesy of Jeff Jenness, Jenness Enterprises, and Pat Iampietro, California State University, Monterey Bay

Surface area based on
elevations of 8 neighbors 3D view of grid

Portions of 8 triangles
overlapping center cell used for

surface area
Center pts of 9 cells connected

To make 8 triangles

Benthic Terrain Modeler
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Click on the Create Rugosity Grids button

Set your working directory to
\Mod1_BTM\BTM_Working

Select the bathymetric grid you will be using as
the input data. Navigate to the Mod1_BTM\Data
folder and select crml_bth grid

Specify the name of the output data as rug

Click Finish to create the rugosity grid

Add the data to your map

Rugosity

1

2

3

4

5

1

2

3

4

5

Benthic Terrain Modeler
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Examine the output data and review questions

Benthic Terrain Modeler

Examine the rug layer in the Table
of Contents section of the
application window. Classify the rug
layer using the slope (red to blue)
color ramp located in the layers
property symbology tab.  The red
area of the rug grids are areas that
are highly “bumpy”.

Right-click the rug layer and click
on Properties…

Click on the Symbology Tab

Select the Stretched

Select the slope color ramp from
the Color Ramp drop down menu.

Check the Invert box
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Examine the output data

Benthic Terrain Modeler

Examine the rug layer with the
hillshade layer.

Uncheck all the layers except the
rug and crml_hs layers.

Right-click on the rug layer and
click on Properties…

In the Display tab, set the
transparency to 70%.

Use the zoom tool to examine the
rug layer. Do the rugosity values
correspond to flat areas and areas
that are high bottom variations
(bumpy)?.
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Module Summary

In this module you used the Benthic Terrain Modeler tool to create a
bathymetric position grid. This grid was used with a classification
dictionary to create a new grid depicting various benthic terrain
zones.
We also created a rugosity grid to measure the bottom complexity or
“bumpiness”. These data layers can be used to examine the physical
characteristics of the seafloor.

Some marine organisms are associated with different types of
seafloor characteristics. For example, certain rockfish species are
found on or near hard and highly complex structures.  Other
organisms such as certain flatfish species are associated with sandy
flat bottoms. Using the BTM, we can quantitatively analyze the
seafloor using multibeam bathymetric grids and begin examining
species-habitat associations.

Project Team:
Dawn Wright, Oregon State University (OSU) Department of Geosciences
Emily Lundblad, OSU Department of Geosciences, now at Joint Institute for Marine
and Atmospheric Research, Coral Reef Ecosystem Division at NOAA Fisheries
Emily Larkin, OSU Department of Geosciences
Ronald Rinehart, OSU Department of Geosciences
Lori Cary-Kothera, NOAA Coastal Services Center
Kyle Draganov, I.M. Systems Group, Inc.
Joshua Murphy, I.M. Systems Group, Inc.
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and Atmospheric Administration (NOAA)
Coastal Services Center.

Related Web Sites
Davey Jones’ Locker (Oregon State
University)
http://dusk.geo.orst.edu/djl/

NOAA Coastal Services Center
http://www.csc.noaa.gov/

Bathymetric Grids were produced by
The Seafloor Mapping Lab at California
State University, Monterey Bay
http://seafloor.csumb.edu/
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About the Instructor
Dawn Wright received her Ph.D. in Physical Geography and Marine Geology from the University of California-Santa
Barbara in 1994. She is currently professor of Geography and Oceanography at Oregon State University. Dr.
Wright's research interests include geographic information science, marine geography, tectonics of mid-ocean ridges,
and the processing and interpretation of high-resolution bathymetric, video, and underwater photographic images.
She has completed oceanographic fieldwork in some of the most geologically-active regions of planet, including the
East Pacific Rise, the Mid-Atlantic Ridge, the Juan de Fuca Ridge, the Tonga Trench, volcanoes under the Japan
Sea and the Indian Ocean, and has also dived three times in the deep submergence vehicle Alvin. Dr. Wright serves
on the editorial boards of the International Journal of Geographical Information Science, Transactions in GIS, and
Geospatial Solutions, as well as on the National Academy of Sciences' National Needs for Coastal Mapping and
Charting Committee. Her most recent books include "Undersea with GIS" (published by ESRI Press, 2002), "Marine
and Coastal Geographical Information Systems" (with Darius Bartlett, Taylor & Francis, 2000), and "Place Matters:
Geospatial Tools for Marine Science, Conservation, and Management in the Pacific Northwest" (with Astrid Scholz,
forthcoming from Oregon State University Press in April 2005).

Dr. Wright is the past recipient of an NSF CAREER award, Excellence in Mentoring awards from the OSU College of
Oceanic & Atmospheric Sciences, and Woman of the Year in Education from Clarity magazine.


