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Document Purpose 
This document will provide a step by step outline, with comments concerning processing 
methods and accuracy issues, for a methodology to create raster grid of shallow-water 
(<20 meters of depth) bathymetric data from multi-spectral satellite imagery.  It records 
image processing steps of the second run through an image specific methodology.  The 
establishment of this methodology will be an iterative process so that processes can be 
improved.  Some of the specifics of each processing step will vary depending on source 
data and file type, however, tools and considerations for each step will be described.   
 
Inputs   
 
Tutuila/Rose 
Multi-beam Sonar (collected by CRED/PIBHMC) 

Collection date: February/March 2004, 2006 
 Data Range:  0- 300 meters 
 Instrument:  240 kHz RESON 8101-ER  
 Resolution:  5x5 meter  

Processing:  Noise editing and conversion to 5 meter grid. 
File Type:  Arc ASCII (.asc) 

 
Tutuila 
IKONOS Satellite Image (purchased from GeoEye, Inc.) 
 Collection date/time: March 3, 2002/21:38 GMT 
 Pertinent bands: Band 1 (blue):  445 – 516 nanometers  
    Band 2 (green): 506 – 595 nanometers   
    Band 3 (red):  632 – 698 nanometers 
    Band 4 (Near IR): 757 – 852 nanometers 
 Resolution:  4x4 meter nominal 

Processing:   Geometric correction (only) 
File Type:  NITF (National Imagery Transfer Format  

 
 
USGS Digital Elevation Model 
  
 



 

Rose 
IKONOS Satellite Image (purchased from GeoEye, Inc.) 
 Collection date/time: March 3, 2002/21:38 GMT 
 Pertinent bands: Band 1 (blue):  445 – 516 nanometers  
    Band 2 (green): 506 – 595 nanometers   
    Band 3 (red):  632 – 698 nanometers 
    Band 4 (Near IR): 757 – 852 nanometers 
 Resolution:  4x4 meter nominal 

Processing:   Geometric correction (only) 
File Type:  ERDAS Imagine (.img) 

 
 
Complete sets of metadata are available. 
 
 
Software Used 
ArcGIS 9.2 
ENVI 4.3 
Microsoft Excel 2003 
S-PLUS (statistical analysis software) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Processing Method: Overview
 
1)  Viewing of Images 
 Software:  ENVI, ArcGIS 
 
2)  Data Conversion from DN (digital number) to Radiance  

Software:  ENVI 
 
Atmospheric Correction (Comments) 
 
3)  Correct for Atmosphere and Water Surface Reflection (deglinting) 

Software:  ENVI, Microsoft Excel 
 
4)  Linearize spectral decay as a function of depth 

Software:  ENVI 
 
5)  Mask Values not Applicable to Depth Derivations 

Software:  ENVI 
 
6)  Georectify Images 
 Software: ENVI, ArcGIS 
 
7)  Extract Linearized Spectral Values and Depth Data 
 Software:  ArcGIS 
 
8)  Perform Multiple Linear Regression Analysis and Derive Bathymetry 

Software:  Microsoft Excel, S-PLUS, ENVI 
 
9)  Integrate Derived Bathymetry with Sonar Bathymetry  
 Software:  ArcGIS 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Processing Method: Step Descriptions
 
1) Viewing and Georectification of Images 
 Making sure that the IKONOS image and multibeam bathymetry grid are 
georectified is a very important preprocessing step because this analysis depends on 
gathering pixel information from the same position in each data source.  Any number of 
issued can arise with image projections and the geometric corrections that the satellite 
imagery undergoes.  Different georectification and file type issues were encountered 
through the first two iterations of this process, first using imagery of Rose Atoll and then 
the Island of Tutuila, are discussed.    
 
 The IKONOS images made available for bathymetric derivations around Tutuila 
were in the NITF format and the multibeam data were in ASCII format.  The NITF files 
cannot be opened directly in ENVI without and additional (and costly) software extension 
and license; however, they can be opened in ArcGIS and converted for use in ENVI.   
 
Additionally, for this iteration, I procured a free “plug in” called “ENVI Reader for 
ArcGIS” that enables the use of the “ENVI Standard” file type in ArcGIS.   The plug in is 
available at http://www.ittvis.com/ and comes with installation and use instructions.     
 
Opening the Bathymetry data in ArcMap (Tutuila and Rose): 
 

• The multibeam bathymetry is in ESRI ASCII format and must be converted to a 
raster to be viewed in ArcMap.  (In my case it was named rose_5m.asc.)  

 
o Use ArcToolbox > Conversion Tools > To Raster > ASCII to Raster to 

create a raster grid of the bathymetry.  
o Use “Float” for output data type  
o Start naming and saving things intelligently – you’ll end up with lots of 

files.   
 

• The spatial reference of both the raster bathymetry and the data view will be 
undefined at this point. 

 
o Use ArcToolbox > Data Management Tools > Projections and 

Transformations > Define Projection to define the projection as defined in 
the metadata.  (D_WGS_1984)  

 Choose the newly converted raster grid as the “Input Dataset”.       
 Use the browse button to define the “Coordinate System” 

• Click the “Select” button 
• Open the “Geographic Coordinate Systems” folder 
• Open the “World” folder 
• Choose “WGS 1984.prj” 
• Click “OK” (twice) 

 

http://www.ittvis.com/


 

o Use ArcToolbox > Data Management Tools > Projections and 
Transformations > Raster > Project Raster to actually project the raster 
that was just defined. 

 Choose the newly defined grid as the “Input raster” 
 Use “Output raster” to save the new raster in the proper place and 

name it wisely. 
 Use the browse button next to “Output coordinate system” to 

provide projection parameters. 
• Click the “Select” button 
• Open the “Projected Coordinate Systems” folder 
• Open the “UTM” folder 
• Open the “Wgs 1984” folder 
• Scroll over to “WGS 1984 UTM Zone 2S.prj” 
• Click “OK” (twice) 

 
It is important to open this file and indicate its spatial reference first so that 
ArcGIS can match up IKONOS data (the spatial reference is different in this case) 
“on the fly”.    

 
The bathymetry raster grid is now ready for use once Ikonos imagery has been 
prepped for processed radiance value extraction – read on! 

 
 
Viewing Ikonos imagery and preparing it for processing in ENVI (Tutuila) 

    
The IKONOS imagery is in NITF format and must first be opened in ArcGIS and 
then converted to a TIFF file for use in ENVI.  Note: Each band (blue, green, red and 
NIR) came as its own file and I needed two scenes for this project.  Thus, four files 
for each scene must be opened and converted and then compiled in ENVI.    
 

• To open the NITF files: 
 In ArcCatalog, with the “Preview” tab active:  

• Left click on the file and say yes to the “Calculate 
Pyramids?” inquiry. 

• Right click on the same file and choose “Calculate 
Statistics” from the options that pop up.   

o Accept the defaults 
 

 Now the files can be previewed in ArcCatalog to choose the 
desired files to include in the ArcMap project. 

• Either drag and drop the files from ArcCatalog to ArcMap 
or use the “Add Data” button within ArcMap. 

 
 The files will once again display as a black box – to view them… 

• Right click on the just added raster layer and select 
“Properties” 



 

• Click the “Symbology” tab 
o For a multi-band image, ensure “RGB composite” is 

highlighted 
o For a single band image, ensure “Strectched” is 

highlighted    
• In the “Stretch” frame  

o Click the “Type” drop down list and select 
“Standard Deviations”   

o Accept the default of 2 and click OK  
 

• To convert the files for use in ENVI 
 In ArcMap, right click on the file in the table of contents.   

• Choose Data > Export Data from the pop up menu 
• From the “Format:” drop down list choose “TIFF” 
• Give the file a good name and storage location and click 

OK 
• The resultant TIFF files can be opened in ENVI with their 

spatial reference data intact.  
 

Opening files in ENVI and multiple processing steps to prepare for bathymetric 
derivations 

 
• To view the files in ENVI: 

 On the main ENVI toolbar, left click on File > Open External File 
> Generic Formats > TIFF/GeoTIFF  

• If the error message “This does not appear to be a valid .tif 
file” pops up, it means you’ve added the files to ArcMap or 
ArcCatalog and still have these programs running.   

• Close whichever ArcGIS projects are running and ENVI 
should open them just fine.   

o To compile the files into a multiband image: 
 In ENVI, have the files you wish to compile active (in the 

“Available Bands List” window) 
 Left click on File > Save File As > ENVI Standard 

• In the “New File Builder” window: 
o Left click on the “Import File…” button 

 Choose the desired bands and click OK 
o Left click on the “Reorder Files…” button, to make 

sure the bands are in the same order as in IKONOS 
data and move them if not.  

 B1 = blue, B2 = green, B3 = red, B4 =NIR  
o Name the file, direct it to a good storage spot and 

click OK 
 
 
 



 

Viewing Ikonos imagery and preparing it for processing in ENVI (Rose) 
 
To View the Data in ENVI: 
 

 Start up ENVI 4.3 and “Open Image File” to open the IKONOS 
(rose_corrected.img) file and use the “Available Bands List” to choose “RGB 
Color” and assign blue, green and red to bands 1, 2 and 3 respectively.   

o In my case this resulted in the image opening up as raster gobbledygook 
(technical term).   

o My trouble shooting resulted in noticing the fact the ENVI was defaulting 
to the NAD27, rather than the WGS84, datum for its UTM co-ordinate 
system.   

 I used the Map > Convert Map Projection from the main tool bar 
to change the datum to WGS84 (using nearest neighbor 
resampling) which caused the image to display properly.   

 However, my exploration of the image exposed the fact the 
positional accuracy of the image was off by about 100 meters as 
judged by the known feature postions. 

• Converting back to NAD27 did not solve the problem.   
 

So, to summarize the problem, the cursor position was not matching to the known 
position of specific geographical features.  There offset was a consistent direction and 
distance from control points.  To me this meant the UTM values assigned to each pixel 
were offset in a specific distance and direction.  My best understanding of the problem is 
that somewhere in the projection conversions threw the positions off some how, but I 
could not get the display to work by any other method.    My decision was to spatially 
subset the data to the area of concern (immediately around the atoll) and to correct the 
offset of the image using the subset.   
 
To Spatially Subset the Image: 
 

 From the main toolbar, use Basic Tools > Resize Data (Spatial/Spectral) 
o In the “Resize Data Input” window  

 Select the right (reprojected) .img file   
 Click the “Spatial Subset” button 

• Click on the “Image” button 
• Use the cursor to drag the box around the area of interest 
• Click OK 

 Leave the “Spectral Subset” as default 
  

o In the “Resize Data Parameters” window 
 Use the default resampling method of Nearest Neighbor. 
 Select a good storage spot for your processed IKONOS imagery 

and name the file. 
 Again, choose wisely, there will be lots of files 

 



 

To rectify the Image: 
In order to correct for the specific direction/distance offset, I decided to change the 
UTM coordinates of the of the origin or “Tie Point” pixel.  This, in turn, shifts the 
coordinates of the rest of the pixels.      

 
• Right click on the name of the file in the “Available Bands List” window and 

choose “Edit Header” 
o Click on the “Edit Attributes” button and choose “Map Info…” 
o In the “Map Coordinate of Tie Point” section of this window you can 

change the UTM position of the upper left corner or tie point of the image.   
o I adjusted the image as an iterative process where I changed the tie point 

position base on my estimate of offset in the image, checked the control 
point apparent location against the physical feature it should represent and 
then adjust the tie point location again to try and account for the remaining 
offset. 

 I achieved a precision of five decimal places, when viewing the 
position data in decimal degrees, after six or seven iterations.   

 
 
2) Data Conversion from DN (digital number) to Radiance  
 
 Satellite imagery comes to the user with the strength of the at sensor radiance 
represented by a digital number (DN).  To this point of the process, it has been OK to just 
use the data in DN values, but for the next step it is essential to convert to radiance.  The 
“calibration coefficients” for this conversion are supplied by the parent company 
(GeoEye, Inc. for IKONOS) and are based on the date of the imagery and radiometric 
resolution of the image.   
 

• The equation to convert DN to radiance is: Radiance = DN/Cal Coeff 
• The coefficients provided were: Blue = 728, Green = 727, Red = 949 and NIR = 

843 
• In the ENVI main toolbar, click Basic Tools > Band Math 
• In the “Band Math” window, create the formulas to utilize the above formula and 

calibration coefficients.  (ENVI help is quite good and very useful in figuring out 
band math.) 

• My “Band Math” equations were thus: 
o float(b1)/728 
o float(b2)/727  
o float(b3)/949 
o float(b4)/843 

• There will now be four “single band” images that will be complied into a 
multiband image later, but, at this point, leave them as single band images for 
further processing. 

 



 

• To facilitate upcoming steps, compile the individual band images in a multi-band 
image as described above ( under Viewing Ikonos imagery and preparing it for 
processing in ENVI (Tutuila)) 

Note about atmospheric correction: 
 Atmospheric correction is essential to deriving depth through the comparison of 
radiance values because atmospheric effects would mask the measure of variable spectral 
band attenuation through the water column upon which this measurement depends.  
Various methods exist for atmospheric correction.  Absolute atmospheric correction 
methods rely on algorithms that use measures of environmental and instrument variables 
to correct and image.  Other methods are more empirical, relying on proxy measures 
within the image used to adjust values for the effects of the atmosphere.  One method (to 
be explored in the future) relies on creating a linear transform based on the brightest and 
darkest pixel value inn each band.  Another, called dark pixel subtraction, is effectively 
applied in images with areas of deep water.  The method relies on the assumption that all 
radiation incident to the water’s surface is either absorbed or reflected.  This darkest pixel 
in the image obviously contains minimal reflected light and the rest of the energy is 
absorbed so that any remaining radiance value in the pixel represents atmospheric effects.  
Subtracting the spectral value of each band in the pixel from its respective band across 
the image corrects for atmospheric effect.   
 
The following process corrects for atmosphere (while also deglinting) in a manner 
analogous to dark pixel subtraction.  
 
 
3) Correct for Atmosphere and Water Surface Reflection (deglinting) 
 
 Variable sun glint across images is a result of the ocean swell and chop causing 
widely variable incident angles for the reflection of the Sun’s radiation.  Methods 
originated by Hochberg, et al. (2003) and refined by Hedley, et al. (2005) are effective in 
removing this glint and improving determinations made from the “de-glinted” imagery.  
The following steps outlined using ENVI functions are based on a four step process 
proposed in Hedley (2005).   
 
Note:  Eric Hochberg (in conversation) suggests that suitable atmospheric correction is 
accomplished by not subtracting the minimum NIR value in the application of the final 
equation in step 4.  This makes steps 1 and the minimum NIR value from step 2 moot, but 
the spatial subset produced in step 2 is still applicable.   The Rose product resulted from 
going through all steps (with step 1 accomplished by dark pixel subtraction).  The 
deglinting/atmospheric correction for the Tutuila product commenced with the spatial 
subset from step 2, through step 3 and uses the adjusted formula in step 4 (below).    
 
 

• 1)  Radiometrically correct image using conventional method.  (Hedley, 2005) 
 

• 2)  Select a sample area (or areas) of the image displaying a range of sun glint, 
but where the image would be expected to be more or less homogenous if the sun 



 

glint was not present (e.g. over deep water).  Determine the minimum Near 
Infrared (MinNIR) value in this sample.   

o In ENVI, use the “ROI Tool” as described above to create and save a new 
ROI that covers a wide range of sunglint. 

o Also in the “ROI Tool”, click on the basic stats button and look at the 
information for Band 4 (which is the NIR).   

• Record the minimum NIR value. 
• You’ll be able to access this figure again later in processing. 

 
• 3)  For each band to have sun glint removed, perform a linear regression of NIR 

brightness (x-axis) against the band signal (y-axis) using the selected pixels.  The 
slope of the regression line is the output of interest. 

o In ENVI use the “ROI Tool” option of “Subset data using ROI” and the 
just made ROI to create a new image that is only the glare pixel subset.   

o Display this new subset image 
o From the main tool bar click File > Save File As > ASCII 

• In the “New File Builder” window, click the “Import File” button 
and choose the glint subset file from the list. 

• Click the “Spectral Subset”  
• Choose the first band  
• Click OK  

• In the “Output to ASCII Parameters” window set the output style 
to XYZ Format.   

• Name the new 1 band file appropriately and store it in the 
right spot.   

• Repeat this process making a file for each of the first four bands 
(blue, green, red, NIR)  

 
o In Microsoft Excel: 

• Open each of the files just created using the formatting wizard 
• Each of the files will have an ID, a UTM position(s), and a 

DN value (we’ve yet to convert to radiance) for each pixel 
• Choose one of the files as your base and compile each of 

the columns of DN values into it 
o Label each column appropriately 
o Have the band 4 column be first in sequence (to 

facilitate using the chart wizard.) 
 

• Use the Chart Wizard, create three different scatter plots with NIR 
DN values on the x axis and the DN values of each of the other 
bands on the y axis.   

• Add a trend line to each of the charts and display its linear 
equation (slope/intercept)   

• Record the slope of each bands trend line from these plots.  
 



 

• 4)  To deglint and atmospherically correct band i for all pixels in the image, 
subtract the product of bi and the NIR brightness of the pixel from the pixel value 
in band i (following equation).  

o R’i = R i - bi (RNIR)  
o In ENVI on the main tool bar, click Basic Tools > Band Math 
o In the “Band Math” window, create the formulas to utilize the above 

formula.   
o In the Tutuila work, (MinNIR was not included) slopes for bands 1, 2 and 3 

were 0.7884, 1.1551 and 0.8781 respectively so that my formulas were 
formatted as follows: 

• float(b1)- 0.7884*float(b4)  
• float(b2)- 1.1551*float(b4)  
• float(b3)- 0.8781*float(b4)  

o In the final “Band Math” window select the files to be referenced by b1, 
b2, b3 and b4 as each formula is used to correct its respective band. 

 
 
4)  Linearize spectral decay as a function of depth (Base on Lyzenga, 1985 - with 
changes suggested by Eric Hochberg) 
 

• Create a spatial subset of the atmospherically corrected and deglinted image from 
step 4. 

o This can be produced using the same ROI/spatial subset process as used in 
step 4-2, but must subset the most recent image. 

 
• Determine the minimum spectral value for each band. 

o From the ENVI main toolbar, select Basic Tools > Statistics > Compute 
Statistics 

o Choose the just created spatial subset as the Input File, click OK 
o Record the minimum value for each band 

• For the Tutuila product my figures were  
• B1: 0.423909 
• B2: 0.261377 
• B3: 0.065501 

 
• Subtract this average value and take the natural log of this figure for the entirety 

of each band.   
o The formula: RLinear = Ln(Ri – Rmin) 
o In ENVI on the main tool bar, click Basic Tools > Band Math 
o In the “Band Math” window, create the formulas to utilize the above 

formula and figures.   
o In the Tutuila work my formulas were formatted as follows: 

• alog (float(b1)- 0. 423909)  
• alog (float(b2)- 0. 261377) 
• alog (float(b3)- 0. 065501)  



 

o In the final “Band Math” window select the files to be referenced by b1, 
b2, b3 as each formula is used to lineraize its respective band. 

 
 
5)  Mask values not applicable to Depth Derivations 
 
Mask NaN Values 
The digital image processing methods conducted in steps 4 and 5 are applicable only to 
deriving depth (or substrate) data from aquatic environments and thus result in rather 
absurd figures for any land areas in the image.  These figures interfere with further 
statistical calculations needed for processing and translation between ENVI and ArcGIS.  
To get rid of irrelevant data: 
 

• Have your three single band files active in the “Available Bands List” window. 
 
• On the ENVI main toolbar, click on Basic Tools > Masking > Build Mask 

o Choose the display that entails the band of interest 
o In the “Mask Definition” window, click the “Options” dropdown list and  

check “Selected Areas “off”” 
o In the “Mask Definition” window, click the “Options” dropdown list and 

select “Mask NaN Values” 
• Highlight the file for which a mask is to be created and click OK. 
• Choose a good output file name and place 
• The mask file will be added to the “Available Bands List”  

o Masks for the other two bands can be created at this point without closing 
the “Mask Definition” window  

 
• On the ENVI main toolbar, click on Basic Tools > Masking > Apply Mask 

o Choose the file to which a NaN mask is to be applied as the input file and 
click OK.  

o In the “Apply Mask Input File” window, click the “Select Mask Band” 
button  

• In the “Select Mask Input Band” window, choose the mask 
appropriate to the input file and click OK.  

o In the “Apply Mask Parameters” window, accept the mask value of 0, give 
the file a good name and location and click OK. 

 
Cloud/Land Masking 
 In the context of converting spectral data to bathymetric information, cloud 
masking serves the purpose of nullifying the value of pixels that contain clouds or cloud 
shadow since accurate depth cannot be derived from this spectral information.   There are 
some methods to create masks by radiance values that may be unique to a feature.  My 
testing of this approach revealed that there was too much spectral overlap between clouds 
and bright sand/coral rubble in shallow areas to employ such a method.  I deemed the 
best approach would be to manually create a cloud/shadow mask by visual assessment of 
the image.    



 

To create a mask and apply it to an image: 
 

• In ENVI, open the desired file.   
o From the main tool bar, click on Basic Tools >Region of Interest > ROI 

Tool 
o With the “ROI Tool” open you can… 

 Use the mouse/cursor to draw shapes around each cloud and its 
shadow 

• Left click and hold it down to drag a line with the mouse 
• Left click and release to register points to be connected 
• Double right click to close and accept each shape. 

 
 Save ROI for later use as a mask 

• In the “ROI Tool” window click on File > Save ROIs…  
• Choose the right region (if more than one made) 
• Save it to a good place with a good name. 

 
• From the image display tool bar, click on Tools > Build Mask… 

o In the “Mask Definition” window: 
 Click on Options and make sure that Selected Areas “Off” and 

Selected Attributes (Logical OR) have checkmarks. 
 Click on Options > Import ROIs 

• If your ROI is active, you can select it from the list.  If it is 
not, you can navigate to the saved .roi file by clicking on 
the “Open ROI file…” button   

• Name and save the mask file in a good spot. 
 

• From the main tool bar, click on Basic Tools > Masking > Apply Mask 
o Select the image to which the mask will be applied as the input file.   
o Click on the “Select Mask Band” button and choose the mask file that was 

just created in the last step. 
 Accept other defaults 
 Name it and put it away 

 
 
6)  Georectify Processed Imagery with Sonar Bathymetry  
 
The IKONOS images are in a Geographic Lat/Long projection with the WGS84 datum 
while the multi-beam data is projected in UTM, zone 2S using the WGS84 datum.    
 
I was not able to solve this problem using just ArcGIS tools, probably because ENVI files 
viewed in ArcGIS cannot be reprojected in ArcGIS.  The solution was the use of both 
programs in re-projection.        
 

• To re-project the ENVI files to correct the geographic offset: 
o On the ENVI main toolbar, click Map > Convert Map Projection 



 

o Select the file of concern and click OK 
 

• In the “Convert Map Projection Parameters” window click on the “Change 
Proj…” button 

o Highlight “UTM” 
o Click the “Datum” button and select “WGS-84” 
o Use the toggle arrows to select zone 2 and be sure to indicate S 

(south) 
o Leave everything else as the defaults (especially the resampling at 

nearest neighbor so that pixel values are not changed). 
o Give the file a good name and storage place. 

 
This file is now in the same projection and has the same spatial reference as the 
multibeam data.  It is also the spatial reference of the Arcmap project (as long as the 
multibeam data was imported first.  However, the actual offset will remain when the file 
is added to the project.  ArcGIS needs to be “told” that this data is in the right projection 
and spatial reference.   
 

• Import the ENVI file into ArcGIS as described above for the importation of the 
Ikonos NTF files.   

 
• In ArcToolbox, select Data Management Tools > Projections and 

Transformations > Raster > Project 
o Choose the imported file that was just reprojected in ENVI 
o The input coordinate system will be referenced from the file 
o Indicate a good name and storage spot for the output file 
o  

To be absolutely sure that the output coordinate system will match that of 
the sonar bathy and the project … 
 

o Click the button to the right of the input box for the “Output coordinate 
system” 

o Click the “Import…” button 
o Navigate to the projected bathymetry file, select it and click OK 
o Verify the displayed information and click OK 
o Accept the rest of the defaults and click OK 

 
NOW the datasets are georectified, however in completing this process I discovered yet 
another issue.  There appears to be a referencing problem when there is extensive use of 
both ENVI files and ArcGIS raster grids in the same ArcMap project even once the files 
are in the same geographic projection.  This throws, again, throws off data referencing by 
point location.  To circumvent this issue, I created an ArcMap project specifically for 
opening and viewing ENVI files and exported each file as an Arc raster grid for use in 
another project for working with the multi-beam bathymetry, processed spectral values 
and derived bathymetry.   
 



 

• To export the ENVI file as an ESRI rater grid: 
o Right click on the file in the project’s table of contents 

 Click Data > Export Data 
 In the “Export Raster Data” window 

• Use the dropdown arrow next to “Format:” to select GRID. 
• Give the file a name of less that 13 characters (Arc rule) 

and click OK.  
 
Note:  It is useful to start putting raster grids that have been prepared for data extraction 
(There should be a bathymetry grid and grids for Ikonos bands one and two that have 
been the applicable steps above.) into a geodatabase.   
 
7) Extract Linearized Spectral Values and Depth Data 
 
 The nuts and bolts description of this step is to open the multibeam sonar and the 
corrected and linearized spectral data and extract data from each of the raster datasets at a 
consistent set of 150 - 200 points.  To get started open the ArcMap project that was 
initiated back in step one.  (or create another one and just re-import the data.) 
 

• If need be, import the bathymetry raster grid and the ENVI files (as described in 
step 1).  

• Double check the georectification of the data as previously described. 
• Create a new point feature class and add it to the project. 

o In ArcToolbox use, Data Management Tools > Feature Class > Create 
Feature Class 

o Based on the overlay between the spectral and multibeam bathymetry 
grids, create on the order of 150 - 200 points by which to spectral and 
depth values. 

 Avoid placing points in areas that have been masked for clouds in 
the ratio data. 

 Avoid placing points in areas where depth exceeds 25 meters. 
o Add location data to each of the points made 

 In ArcToolbox, open Data Management Tools > Features > Add 
XY Coordinates 

 Input the point feature just created 
 Open the attribute table of the feature to verify addition of x, y 

locations 
• Extract the data from both the multibeam sonar grid and the spectral data grids 

o In ArcToolbox, open Spatial Analyst Tools > Extraction > Extract Values 
to Points 

 Choose the point feature with x, y locations as the input point 
feature and one of the raster grids as the input raster. 

 Name and locate the output file properly 
 Add the feature to the project (should be automatic) 
 Repeat this with the other data sets 



 

 The .dbf file (of the several created) can be opened in Excel for the 
next step  

 
 
7) Perform multiple linear regression analysis and use the resultant formula and 
coefficients to derive depth  
 

• Create a new Excel worksheet and use the import wizard to open each .dbf file 
created by ArcGIS for each of the extracted point features. 

o While using the import wizard, begin with row 5 so that the header 
information is not included when opened in excel. 

o Use the extracted depth file as a base and copy/paste the linearized blue 
and green spectral values into two additional columns.  

 Label columns appropriately 
 Save the file 

 
Note:  There are a number of statistical analysis software programs available for the 
performance of a multiple linear regression analysis.  S-PLUS what was available to me 
and the description of how I used it follows.   
 

• Perform a multiple linear regression using S-PLUS. 
o On the main toolbar, click File > Import Data > From File 

 In the “Import from File” window, click the browse button and 
navigate to the Excel file that was just created 

 Leave the defaults and click OK 
o On the main toolbar, click Statistics > Regression > Linear… 

 In the “Liner Regression” window under the “Model” tab 
• Click the dropdown arrow next to “Dependant:” and choose 

the name of the column that contains the extracted depths. 
• Use the scroll bar next to “Independent:” and choose the 

names of the columns that contain the extracted linearized 
spectral data for the blue and then the green bands 

• Nest to “Formula:” a formula that looks something like: 
Depth~Band.1.2+Band.2.2 will appear 

 All the defaults under all the other tabs should be fine, so click OK 
 Lots of statistics will result; the figures important to this analysis 

are the coefficient values that appear as follows: 
 Example Data: 

Coefficients: 
              Value Std. Error   t value  Pr(>|t|)  

(Intercept) 6.0839   3.3739     1.8032   0.0731 
      Band.1.2  -2.6775   1.2128    -2.2077   0.0286 
      Band.2.2  11.6426   2.1936     5.3074   0.0000 

 
o The applicable formula is not immediately apparent in the program, but it 

is of the form:  D = a + (bi)(xi) + (bj)(xj)   
 Where: 



 

• D = depth 
• a = intercept 
• b = slope 
• x = the linearized spectral value (radiance - radiancemin) 

calculated in step 4.   
 

• Use ENVI to derive depths. 
o Open the ENVI files that have been taken all processing steps previously 

performed in ENVI. 
o On the main tool bar, click Basic Tools > Band Math 
o In the “Band Math” window, create the formulas to utilize the above 

formula and figures.   
o Using the above information the ENVI band math formula would be of the 

form:  6.0839 – 2.6775*float(b1) + 11.6426*float(b2)  
 
Note:  At this juncture it’s important to point out that neither step 7 nor this entire process 
is as straight forward or “fool proof” as the instructions might imply.  Regarding step 7, I 
went through several iterations before I had a product that I was satisfied with.  I repeated 
it with extracted values correlated with depth of < 25 meters, < 20 meters and < 15 
meters.  The < 20 meter product was the most satisfactory, but I still came up with 
positive values in areas that I was sure (from on site experience and a good look at the 
original image) had shallow depth of water.  My solution to this was to “bring in the tide” 
by adjusting the Y intercept value to produce deeper depths.  This adjustment resulted not 
only in depths figures where values were positive, but also in a better match of deeper 
derived depths with the multi-beam bathymetry.   
 
 Regarding the whole process, I’ve only derived satisfactory shallow water 
bathymetry for one of the two images that I was working with for Tutuila.  My successful 
product resulted from an image (central Tutuila) with close to flat calm conditions.  The 
product for western Tutuila had much more severe glint conditions and my product had a 
depth range of only ~2 meters, between 10 and 12 meters.  Communication with Eric 
Hochberg indicates that the glint in the image is extreme and that multiple negative 
values result from the lint correction due to likely whitecaps in the image.  High quality 
original imagery is paramount.             
 
 
8) Integrate Derived Bathymetry with Sonar Bathymetry  
 
Derived Bathymetry preparation and integration 
 

 Import the ENVI derived bathymetry file (step 6) into the project containing the 
multi-beam bathymetry. 

o Verify georectification  
 

 Edit the derived bathy grids so that only grid cells with a value between -20 and 0 
contain data as follows: 



 

 
• Reclassify the derived bathy grids into a new raster where each grid cell with a 

value between 0 and -20 is changed to 1 and values outside this range are changed 
to NoData.   

 
o Use (in ArcToolbox) Spatial Analyst Tools > Reclass > Reclassify to 

create a new raster grid 
 Click the “Classify” button 
 Use the dropdown list to change “Method” to Equal Interval 
 Change the number of “Classes” to 3 
 Change “Method” back to Manual 
 Set the displayed “break values” to: 

• -20 
• 0 
• The maximum positive default (This should be the 

default, however, I’ve had the program fail to recognize 
the highest positive value.  I this occurs, simply set the 
positive value sufficiently high to include unrecognized 
values.)  

o Click “OK” 
 Assign all of the pixels that had a value between 0 and -20 a new 

value of 1. 
 Assign all of the pixels that had a value outside of this range a new 

value of “NoData”. 
• Click “OK” 

 
o Use Raster Calculator to multiply the values in this new grid by the values 

in the derived bathy grid. 
 Open “Raster Calculator” which is found in Spatial Analyst tools. 
 In the “Raster Calculator” expression builder window: 

• Double click on the derived bathymetry grid  
• Click once on the multiply button 
• Double click on the reclassified image that has only has 

values of “1” and “NoData” 
o Verify that the displayed formula is correct 
o Click “OK” 
o  

 A “calculation” will be added to the ArcMap layers menu, this file 
is temporary and must be made permanent 

• Right click on the “calculation” and choose “Make 
Permanent” 

• Save it in a good place and give it a good name. 
 

 Mosaic the derived bathymetry raster grids 
 

o Use Data Management Tools > Raster >Mosaic 



 

 The “Input Raster” is the image that will be added to the target. 
 The “Target Raster” is the image to which the input raster will be 

added 
• Important Note:  This file will have the new raster data 

added to it without a chance to rename the output, so, if you 
want the “target image” original to be maintained, save a 
copy of it somewhere.   

 
 Choose the “Mosaic Method” wisely: 

• “First” for “Mosaic Method” gives the raster values of the 
Target Raster priority so that they will replace the values of 
coincident raster cells from the Input Raster 

• “Last” for “Mosaic Method” gives the raster values of the 
Input Raster priority so that they will replace the values of 
coincident raster cells from the Target Raster 

 
 Choose the “Colormap Method” – same relationship applies.  
 The rest of the setting should be fine but: 

• Double check that “Convert 1 bit data to 8 bit” is 
unchecked 

• The other settings can be useful – read up! 
 

Note:  I mosaiced each of the four Tutuila images one at a time to assure that the 
correct image was assigned priority for grid cell value replacement using “First” 
and “Last” as just described.  The derived bathymetry for rose all came from one 
image so that mosaicing was not required at this juncture.   

 
However, in each case extra (bogus) derived depth values extended outside of the 
limits of the sonar bathymetry so that it needs to be trimmed for a proper mosaic.  

 
 To trim the derived bathymetry 

o Create a polygon feature class 
 Draw a polygon that covers the edge of the derived bathymetry 

that is to be trimmed.   
 Note:  This polygon will be converted to a binary raster 

(NoData/1) to multiply by the derived bathy to trim it.  In the 
conversion, Arc creates a rectangular grid out of what will most 
likely be an odd shaped polygon.  So that the binary grid will 1’s in 
the entire area of values to be retained, extend the tips of the 
polygon out so that the resultant grid will cover the whole image.  
(This will make sense after a couple of tries.) 

 
o Convert the polygon to a raster grid. 

 Use Conversion Tools > To Raster > Feature to Raster  
• Provide the polygon as the “Input feature” 



 

• For “Field” either “area value” or “length value” works 
fine. 

• For “Output cell size” use the browse button to navigate to 
the derived bathy grid to be trimmed and choose it as the 
reference file for grid cell size.   

o Click “OK”  
 

o Reclassify this image as described above (in this section), but:  
 “Break Value” defaults should be fine this time.  
 Reassign pixel values so that:   

• “NoData” is changed to “1” 
• The value equal to what would have been polygon area or 

length (depending on the choice above) is changed to “0” 
• Use “Add classification” button to add a new classification 

line and indicate that values of “0” are changed to “1” (or 
there will be large block with a value of 0 in the middle of 
the grid).  

 
 Resample the derived bathy grid so that its grid cell sizes (now 4 meter) match up 

with the 5 meter sonar bathy grid 
o Use Data Management Tools > Raster > Resample 
o In the “Resample” window: 

 Indicate the input raster and give the output a good name and 
location 

 Navigate to the bathymetry file to use it as a grid cell size 
reference (or indicate a “Output Cell Size” of 5) 

 Choose the  “Resampling Technique” of Nearest Neighbor. 
• Click OK 

 
Sonar Bathymetry preparation 
 
Initially the sonar bathymetry grid had large gaps where the sonar swaths did not overlap.  
Use the ArcGrid command line window and the following commands to fill these gaps. 
 

• To open the ArcGrid command line window: 
o Click the “Start” button in the lower left of your main Windows display 

and mouse through the dropdown lists to Programs > ArcGIS > ArcInfo 
Workstation > Grid 

 The command line window will have the command prompt of 
Grid: visible.  This is the important window. 

 The other window is for displaying grids, I minimized and did not 
use it since I was working interactively with an open project.   

  
o To create a workspace (reference to where the desired files are stored) 

type: 
 Grid: arc CREATEWORKSPACE <path> 



 

• “arc” directs the program to interpret files in the workspace 
as arc files. 

• <path> should be where the grids to be worked with are 
stored. 

o Example: 
J:\hogrefek\TutCTM_0108\Tut_Ikonos_GRD_2 

   
o To direct ArcGrid to this workspace (so the program knows where to find 

files): 
 Grid: arc WORKSPACE <path> 

 
o Enter the expression that will begin filling gaps of “NoData” values in the 

bathymetry grid without changing original data values.  Type: 
 Grid: New_Grid = 

con(isnull(Old_Grid),focalmean(Old_Grid,rectangle,4,4),Old_Grid) 
• “New_Grid” should be replaced by the name for the new file 

with gap fills.   
• “Old_Grid” should be replaced by the input file with gaps.    
• Type “help” at the Grid: prompt to access full descriptions of 

the commands involved in this expression. 

 Description of this function’s utility, as found at ESRI Support 
(http://support.esri.com/ ) follows: 

I did find another solution in the ArcInfo mosaic help text:  
 
"The MOSAIC function itself will not interpolate to fill missing data 
which may happen while putting a set of grids into one composite entity. 
The following GRID expression may help to solve the problem by 
interpolating values of the missing cells. It will fill gaps of up to three 
rows or columns of NODATA cells (the length of the gap is unrelated) 
with the mean cell value of the 4 x 4 square, leaving the valid existing 
data unchanged.  If the gap is wider than 3 cells, the size of the focal 
window may be very conservatively increased.  
 
Grid: final_mosaic = con(isnull(gap_mosaic), focalmean(gap_mosaic,  
rectangle,4,4), gap_mosaic) "  
 
My gap was a max of 5 cells wide so I increased the focal window to a 
6x6 square. You also have to change the "final_mosaic" to a new grid 
name and the "gap_mosaic" to your old grid name with the gaps in it. 
This worked great for me, filling the entire gap without changing values 
anywhere else.  Fortunately my gaps were in areas of very little 
topographic change so a mean of the surrounding cells is okay, if you are 
interpolating over an area of high relief this command may not be 
appropriate.  
 



 

 It may be necessary to run multiple iterations of the expression to 
entirely fill gaps, by replacing the input file with the most recent 
gap filled file and changing the output file name. 

 
o Once the “NoData” gaps are filled to the analyst’s satisfaction, the grid is 

ready to mosaic with the derived bathymetry mosaic.   
 The edges of the raster that you gap filling will get new values too.  

This could effect the how well the derived and sonar bathy values 
match up along this edge (could be beneficial!). 

 More gap filling will occur to later grid mosaics, some remaining 
gaps are OK as long as now unwanted values are showing through 
“NoData” pixels. 

 
DEM preparation 
 
The DEM was initially in the NAD1983 datum using the GRS80 ellipsoid with a 
resolution of 10 meters. 

• When the DEM opened in ArcMap it had no geographic reference. 
• In ArcToolbox use Data Management Tools > Projections and Transformations 

> Define Projection as described earlier in Viewing and Georectification of 
Images.  Except … 

o In “Geographic Coordinate Systems” choose “North America” and choose 
“North American Datum 1983.prj” 

 Click “OK” 
o Now the DEM can be reprojected 

 
• In ArcToolbox use Data Management Tools > Projections and Transformations 

> Raster > Project as described earlier in Viewing and Georectification of 
Images.  Except … 

o Note that the “Input coordinate system” is NAD83 as you just defined it. 
 This is fine, for  “Output coordinate system” use the “Import” 

button as described to assign WGS_1984_UTM_Zone_2S  
 Click “OK” 

 
• In ArcToolbox use Spatial Analyst Tools > Reclass > Recclassify to change the 

grid cell size from 10 meter resolution to 5 meters as described previously in this 
section. 

o Float?????  
 
Mosaic Derived Bathy, Sonar Bathy and DEM  
 
At this point all raster grids should be in the same projection and have the same raster 
resolution and may have some preliminary “NoData” gap filling done.  Time to Mosaic! 

• Mosaic the sonar and derived bathy grids using Data Management Tools > Raster 
> Mosaic as recently described in this section. 



 

o The sonar bathy is most likely most correct, so assure that grid cells from 
the sonar bathy get priority in the mosaic. 

 
• Fill “NoData” gaps that exist in the new mosaic using the ArcGrid command line 

window and the provided expression as described above. 
 
Note:  Small “Nodata” gaps left from bogus depth derivations in surf and shallow 
reef areas were filled with three or four iterations of running the expression.  
These values can be considered a good estimate of what the depth derivation 
process might have predicted. 
 
 Large “Nodata” gaps left from cloud masking were also filled using the 
gap fill expression.  In the case of the largest gaps, it took 30 iterations to fill 
them.   Of course, the further away from the edge of the original data, the more 
questionable the depths estimated by the expression.  However, no handier or 
more accurate method exists within Arc (to my knowledge) to accomplish these 
fills without changing original data in the raster.  Further, as the edge of estimated 
depths advances across gaps through multiple iterations, previously estimated 
values are not changed resulting in a progressive estimate across the gaps.  
Though I would not consider these estimated area specifically accurate 
representation of the terrain in the area, I would consider them reasonably 
accurate estimate of the terrain based of the best available data.   
 
 There are many questionable depth values that advance into the “NoData” 
hole that represents the island.  These values will be superseded by DEM land 
values in the next mosaic step.    

 
• Once satisfied with the combined sonar/derived bathy mosaic add the 5 m 

resolution DEM by once again using Data Management Tools > Raster > 
Mosaic. 

o The DEM is most likely most correct where the grids overlap, particularly 
if extensive gap filling has been conducted as noted just above.  So, assure 
that grid cells from the DEM get priority in the mosaic.  

o Gap filling could be conducted once again if determined necessary. 
 
 
Coastal Terrain Model Ho! 
 


